Back to overview
Ethereum blocks data is lagging for approx 4 hours
Apr 24, 2026 at 11:39am UTC
Affected services
Ethereum
Resolved
Apr 24, 2026 at 11:39am UTC
We are investigating!
Affected services
Resolved
Apr 24, 2026 at 11:39am UTC
We are investigating!
Affected services