Back to overview
Degraded
Arbitrum inaccurate data
Jul 22, 2026 at 6:08am UTC
Affected services
Arbitrum
Updated
Jul 24, 2026 at 6:48pm UTC
Arbitrum data is stale. We are mitigating the issue.
Affected services
Created
Jul 22, 2026 at 6:08am UTC
Arbitrum data on block, logs, transactions, traces and all downstream have bad data on 2026-07-22 due to a RPC bug. We are investigating the issue.
Affected services