Back to overview
Resolved

Bitcoin data is stale

Jul 6, 2026 at 9:30pm UTC
Affected services
Bitcoin

Resolved
Jul 6, 2026 at 11:02pm UTC

The issue is that new bitcoin blocks are getting minted at a much slower rate, so there is no new data to process

Created
Jul 6, 2026 at 9:30pm UTC

We are experiencing staleness on bitcoin blocks, logs and traces + downstream. Our team is working on the fix