Back to overview
Degraded

Bitcoin data is stale.

Jun 11, 2026 at 8:52am UTC
Affected services
Bitcoin

Updated
Jun 11, 2026 at 10:11am UTC

Root cause was identified and a fix was shipped. The indexing is resuming

Created
Jun 11, 2026 at 8:52am UTC

Bitcoin data and downstream are stale, stopped progressing. We are investigating the issue.