Back to overview
Degraded

Ethereum data is delayed

Jun 5, 2026 at 8:18pm UTC
Affected services
Ethereum

Resolved
Jun 5, 2026 at 10:21pm UTC

We have identified and fixed the issue.

Created
Jun 5, 2026 at 8:18pm UTC

Ethereum data on Dune is currently delayed — new blocks, logs, and traces
after 13:57 UTC are not yet available, and queries against Ethereum tables
may return incomplete recent data. Other blockchains are not affected.