Back to overview
Degraded

SEI blockchain data is stale

Apr 16, 2026 at 1:40pm UTC
Affected services
SEI

Resolved
Apr 16, 2026 at 8:28pm UTC

Data is up to date

Updated
Apr 16, 2026 at 3:12pm UTC

Root cause identified and fixed. Data ingestion has resumed.

Created
Apr 16, 2026 at 1:40pm UTC

We are 592k blocks behind and are investigating the root cause