Back to overview
Taiko blockchain data is lagging behind by 20 hours
Apr 2, 2026 at 7:50am UTC
Affected services
Taiko
Resolved
Apr 2, 2026 at 7:50am UTC
Data is up to date
Affected services
Resolved
Apr 2, 2026 at 7:50am UTC
Data is up to date
Affected services