Back to overview
Degraded
Celo blockchain data is lagging behind by 20 hours
Apr 2, 2026 at 7:49am UTC
Affected services
Celo
Updated
Apr 2, 2026 at 1:29pm UTC
Root cause identified and fixed. Data is catching up
Affected services
Created
Apr 2, 2026 at 7:49am UTC
Celo blockchain data is lagging behind by 20 hours
Affected services