Back to overview
Degraded
bnb source data is behind
Feb 28 at 01:44am CET
Affected services
Curated Data Tables
BNB Chain
Updated
Feb 28 at 10:01am CET
We identified the root cause. Data is catching up. ETA 6hours
Affected services
Created
Feb 28 at 01:44am CET
Data last updated around 2026-02-26 21:35 UTC. We are investigating the delay.
Affected services