Back to overview
Degraded

Duplicated data on Snowflake

Feb 23 at 09:49am CET
Affected services
Snowflake

Resolved
Feb 24 at 03:16pm CET

Duplicates on Snowflake for February 20th and February 21st are resolved.

Updated
Feb 24 at 10:50am CET

We have implemented a fix and have further determined the extend of the duplicates. We're starting the process to remove the duplicates from the tables.

The duplicates where inserted for data in the following periods:
[2026-02-21 00:00 UTC - 2026-02-21 08:00 UTC]
[2026-02-22 00:00 UTC - 2026-02-22 08:00 UTC]

Updated
Feb 24 at 10:24am CET

We have identified the root cause and are working towards a resolution.

Created
Feb 23 at 09:49am CET

Duplicate records are present on Snowflake tables from February 20th. We are investigating which tables are affected and looking for a mitigation.